Railsメモ

2013年7月3日

rakeのバージョンが違うと怒られたとき

rakeのバージョンあげちゃって怒られるの巻。

$> rake db:migrate
You have already activated rake 10.0.3, but your Gemfile requires rake 0.9.2.2. Using bundle exec may solve this.

バージョンを指定してあげましょう

$> rake _0.9.2.2_ db:migrate
You have already activated rake 10.0.3, but your Gemfile requires rake 0.9.2.2. Using bundle exec may solve this.

deviseのログアウトでrouting error

config/initializers/devise.rbのconfig.sign_out_viaを:deleteから:getに変更してみましょう。
他への影響は知らん。

  # The default HTTP method used to sign out a resource. Default is :delete.
  config.sign_out_via = :get

RubyOnRails | majin | 12:22 | Comments (0)

コメントはまだありません »

No comments yet.

コメントRSS

Leave a comment

Copyright © MAJIN_T
Powered by WordPress